Please refer below for the Status Codes and Solutions.
Status Code | Description |
Product key is already used on another machine | |
This key cannot be deauthorized because it was authorized on a machine with a different machine signature | |
Product key is already used on this machine | |
User lacks the appropriate rights to authorize or deauthorize a key | |
Internet connection cannot access licensing server |
Status Codes and Solutions Detail
7313: Product key is already in use on another machine.
Likely causes:
- Changes to the physical server or virtual machine running PSQL/Zen caused the machine signature to change. The Status of the license will be set to Failed Validation or Disabled
- Solution: Repair the license. In later versions there is an option to perform a Self Repair. If that fails, or is not available you will need to reach out to Actian or your OEM provider for assistance.
- Key was authorized on another machine that crashed so that PSQL/Zen is not accessible.
- Solution: Reset the key. This needs to be done by the vendor who created the key (Vendor 0 = Actian, other vendors are Actian PSQL OEM partners.)
- Resets remove the the machine association from the license so that it can be Authorized on a new machine.
- Key is authorized on another working machine.
- Solution: A PSQL/Zen license can only be on one machine. The solution is to Deauthorize the license on the machine the license is on or purchase a new license.
7314: This key cannot be deauthorized because it was authorized on a machine with a different machine signature.
Likely causes:
- The hardware signature of the original machine has changed, or The key is being used on a different machine.
- Solution: The solution would be the same as with a Status Code 7313
7315: Product key is already used on this machine.
Likely cause:
- The license is already Authorized on the machine. Verify the license that is Authorized via the License Administrator.
7224: User lacks the appropriate rights to authorize or deauthorize a key
Likely cause:
- Running PSQL/Zen Workgroup without Windows Administrator access.
- Solution 1: Run Elevated
1. Close any applications and stop the workgroup engine (w3dbsmgr.exe) either on the task bar, or through Task Manager.
2. Open My Computer and navigate to C:\Program Files (x86)\Actian\PSQL\bin.
a. Depending on the version, the path may be different.
3. Find and right-click w3dbsmgr.exe choose Run As Administrator.
4. Find and right-click guilcadm.exe Choose Run As Administrator.
5. Try to Deauthorize and Authorize again. - For Zen V14 Workgroup and later:
1. Close any applications and Stop the workgroup engine (zenengnapp.exe) using the Task Manager.
2. Open My Computer and navigate to C:\Program Files(X86)\Actian\Zen\bin.
3. Find and right-click zenengnapp.exe choose Run As Administrator.
4. Find and right-click guilcadm.exe choose Run as Administrator.
5. Try to Deauthorize and Authorize again.
7239: Internet connection cannot access licensing server
The Internet connection cannot access the licensing server to obtain data needed for key validation. Possible causes include, but are not limited to, the following:
- A network problem is preventing connection to the Licensing Server.
- In your local system registry, authorization server information may be corrupt or missing.
- Security issues, such as firewall protection, are preventing connection to the authorization server. Configure your firewall or proxy server to allow access to elspv.pervasive.com and bkpelspv.pervasive.com. Additional details can be found in a knowledge base article.
- Actian PSQL/Zen licensing server is down.
- Solution: Paste elspv.pervasive.com into your browser. If the licensing server is up, it will answer with a message like – ELS WEB SITE AMS11 version 1.5.2 Build 70 – 11.30.0.14