Client-Server applications use the TLS protocol to communicate across a network in a way designed to prevent eavesdropping and tampering. The PCI Security Standards Council has declared that TLS 1.0 or 1.1 no longer meet minimum security standards due to security vulnerabilities for which there are no fixes. 

Please have your IT professional review the following Microsoft document: How to enable TLS 1.2

 

There are 2 additional items to consider in relation to TLS 1.2:

  1. If you are processing integrated credit card transactions using Netepay. You may require a reinstallation (same version – newer install, no upgrade fee)
  1. If you email from System Five using Outlook 365 (using SMTP) you will require  System Five Version 6.2.4.171 or higher 

 

If require an update to version 6.2.4.171 or higher you can have your IT self serve an update following the instructions HERE

 

Please have your IT examine any managed firewalls to ensure they are using TLS 1.2 or greater


Ensure you are using web browsers that use TLS 1.2 or greater. Supported browsers include:

 - Google Chrome, version 29 and higher

 - Mozilla Firefox, version 27 and higher

 - Microsoft Internet Explorer, version 11 and higher

 - Microsoft Edge

 - Apple Safari, version 7 and higher