Issue
The remote desktop window closes after 40 seconds during Multi-factor authentication (MFA), preventing the user from authenticating and accessing the VM.
Cause
There is some sort of a built-in timeout policy in Windows that causes the remote desktop window to close when it detects inactivity for 40 seconds. The issue mostly happens on users who authenticate using email, where the user minimizes or switches windows to access their email to get the code, leaving the remote desktop session "inactive" (no mouse or keyboard input) and closes after 40 seconds.
Solution #1
For users who authenticate by email, keep the remote desktop session "active" by moving the MFA window around the screen (click-and-drag) every few seconds while waiting for the codes sent to the email address:
Solution #2
Add or switch to Microsoft Authenticator app. The authenticator app constantly generates codes and works offline so the user will not have to wait for the codes.
If for some reason, the Microsoft Authenticator app is not a possible solution, the user can also setup the Microsoft Authenticator in a browser extension form.
- https://support.windwardsoftware.com/a/solutions/articles/66000524460
- https://support.windwardsoftware.com/a/solutions/articles/66000525315
Solution #3
If for some reason, the user isn't receiving the codes or the codes from the authenticator app aren't working, the user can use backup code:
THE BACKUP CODE NEEDS TO BE MANUALLY GENERATED FROM THE MFA WEB PORTAL FIRST BEFORE IT CAN BE USED